JoinGeometry Method


Join Geometry Utils Join Geometry Method

Creates clean joins between two elements that share a common face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void JoinGeometry(
	Document document,
	Element firstElement,
	Element secondElement
)

Parameters

document Document
The document containing the two elements.
firstElement Element
The first element to be joined.
secondElement Element
The second element to be joined. This element must not be joined to the first element.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are already joined. -or- The elements cannot be joined.
ArgumentNullException A non-optional argument was null
InvalidOperationException Please remove or add segments on curtain grids instead of joining or unjoining geometry of the panels.
Remarks
The visible edge between joined elements is removed. The joined elements then share the same line weight and fill pattern. This functionality is not available for family documents.
See Also