ExternalResourceLoadStatus Enumeration


External Resource Load Status Enumeration

A flag to indicate the status of an ExternalResource load request.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ExternalResourceLoadStatus
Members
Member name Value Description
CannotFindServer 4 The server identified by the ExternalResourceReference could not be found, and may not be registered.
Failure 1 The load operation failed.
ResourceAlreadyCurrent 3 The current version of the resource is already loaded into Revit so no changes were made to the model.
ServerThrewException 5 The server identified by the ExternalResourceReference threw an exception while attempting to load a resource.
Success 0 The load operation was successful.
Uninitialized 2 The load operation is in an incomplete state. Revit will treat this result as a failure.
Remarks
This flag is returned by the LoadResource method of the IExternalResourceServer class to inform callers whether the load operation succeeded, or encountered an error.
See Also