Repeating |
Returns the default repeating reference source for a given element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static RepeatingReferenceSource GetDefaultRepeatingReferenceSource(
Document document,
ElementId elementId
)
Parameters
- document Document
- The document that contains the element.
- elementId ElementId
- The id of the element.
Return Value
RepeatingReferenceSourceThe default repeating reference source of the given element.

Exception | Condition |
---|---|
ArgumentException | The element elementId does not exist in the document -or- The element does not have any repeating reference sources. |
ArgumentNullException | A non-optional argument was null |

The element must support repeating references. Use HasRepeatingReferenceSource() to find out whether an element has any repeating references.