AdvancedLayered Class


Advanced Layered Class

A static class that provides access to the property names that appear in the AdvancedLayered visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual AdvancedLayered

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class AdvancedLayered

The AdvancedLayered type exposes the following members.

Properties
Name Description
Public property Static member LayeredAnisotropy The property labeled "Anisotropy" from the "AdvancedLayered" schema.
Public property Static member LayeredBottomF0 The property labeled "Color" from the "AdvancedLayered" schema.
Public property Static member LayeredDiffuse The property labeled "Color" from the "AdvancedLayered" schema.
Public property Static member LayeredF0 The property labeled "Clearcoat reflectance" from the "AdvancedLayered" schema.
Public property Static member LayeredFraction The property labeled "Fraction" from the "AdvancedLayered" schema.
Public property Static member LayeredNdfType The property labeled "NDF" from the "AdvancedLayered" schema.
Public property Static member LayeredNormal The property labeled "Image" from the "AdvancedLayered" schema.
Public property Static member LayeredRotation The property labeled "Rotation" from the "AdvancedLayered" schema.
Public property Static member LayeredRoughness The property labeled "Roughness" from the "AdvancedLayered" schema.
Public property Static member SurfaceAlbedo The property labeled "Color" from the "AdvancedLayered" schema.
Public property Static member SurfaceAnisotropy The property labeled "Anisotropy" from the "AdvancedLayered" schema.
Public property Static member SurfaceCutout The property labeled "Image" from the "AdvancedLayered" schema.
Public property Static member SurfaceNdfType The property labeled "NDF" from the "AdvancedLayered" schema.
Public property Static member SurfaceNormal The property labeled "Image" from the "AdvancedLayered" schema.
Public property Static member SurfaceRotation The property labeled "Rotation" from the "AdvancedLayered" schema.
Public property Static member SurfaceRoughness The property labeled "Roughness" from the "AdvancedLayered" schema.
Top
See Also