AddPartCustomData Method


Fabrication Part Add Part Custom Data Method

Add custom data type to the fabrication part. The new data gets the default value defined by the fabrication configuration.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool AddPartCustomData(
	int customId
)

Parameters

customId Int32
The identifier of the custom data field to add.

Return Value

Boolean
Returns true if the type was not already present.
Exceptions
Exception Condition
ArgumentException The custom data identifier does not exist.
Remarks
The custom id must be positive.
See Also