Image |
Creates a new ImageType element and loads the image into it.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- The document.
- options ImageTypeOptions
- Options that specify what image to load.
Return Value
ImageTypeThe new ImageType.

Exception | Condition |
---|---|
ArgumentException | The image filename is an empty string. -or- The image file is not a supported image file type. -or- The image file is password protected. -or- The image file does not contain the requested page number. -or- The image file could not be read and may be corrupt. -or- An error occurred while handling the external resource corresponding to the image. |
ArgumentNullException | A non-optional argument was null |
FileArgumentNotFoundException | The image file does not exist. |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |

The ImageType will be created but will not be placed into any view.