Datum |
Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders).
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- datumEnd DatumEnds
- The end of the datum plane.
- view View
- The view on which the DatumPlane shows.
- leader Leader
- The Leader for setting the datum plane.
Return Value
BooleanTrue if the leader is valid for set leader, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
InvalidOperationException | This datum plane has no leaders. -or- The DatumPlane should not have a leader. |

If the view or leader is null, it will throw ArgumentNullException; A valid leader meets the following conditions:
- The leader's End, Elbow and Anchor should lie in the View's plane
- The End of the leader should be on the datum plane's curve(s)
- The Elbow of the leader should be between the End and Anchor