PlanTopology Class


Plan Topology Class

An object that represents a Plan Topology within the Autodesk Revit project.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB PlanTopology

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PlanTopology : APIObject

The PlanTopology type exposes the following members.

Properties
Name Description
Public property Circuits The Circuits of the PlanTopology.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Level The Level of the PlanTopology.
Public property Phase The phase of the PlanTopology.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetRoomIds Retrieves room ElementIds of the PlanTopology in the last phase.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
This object derived from the APIObject base object. It can be used access the properties of a Plan Topology.
See Also