EdgeEndPoint Class


Edge End Point Class

Represents the start or the end point of an Edge.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB EdgeEndPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class EdgeEndPoint : IDisposable

The EdgeEndPoint type exposes the following members.

Constructors
Name Description
Public method EdgeEndPoint Constructs an instance of EdgeEndPoint.
Top
Properties
Name Description
Public property Edge The Edge.
Public property Index The index of the start or the end point of an Edge: 0 is the start point, 1 is the end point.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the EdgeEndPoint
Public method Equals(EdgeEndPoint) Determines whether this EdgeEndPoint is equal to another.
Public method Equals(Object) Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Evaluate Evaluate the end point of the edge in 3d coordinates.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also