IFCData Class


IFCData Class

A specialized type of abstract data block that can represent any data type.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC IFCData

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCData : IDisposable

The IFCData type exposes the following members.

Constructors
Name Description
Public method IFCData Creates a copy object.
Top
Properties
Name Description
Public property HasValue Identifies if the data is empty or contains a value.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property PrimitiveType The primitive data type.
Top
Methods
Name Description
Public method AsAggregate Gets storage value as IFCAggregate when its PrimitiveType is aggregate.
Public method AsBoolean Gets storage value as boolean when its PrimitiveType is boolean.
Public method AsDouble Gets storage value as double when its PrimitiveType is double.
Public method AsInstance Gets storage value as IFCAnyHandle when its PrimitiveType is instance.
Public method AsInteger Gets storage value as integer when its PrimitiveType is integer.
Public method AsLogical Gets storage value as IFCLogical when its PrimitiveType is logical.
Public method AsString Gets storage value as string when its PrimitiveType is string, binary or enumeration.
Public method Static member CreateBinary Creates a binary data object.
Public method Static member CreateBoolean Creates a boolean data object.
Public method Static member CreateBooleanOfType Creates a boolean data object of the specified type.
Public method Static member CreateDouble Creates a double data object.
Public method Static member CreateDoubleOfType Creates a double data object of the specified type.
Public method Static member CreateEnumeration Creates a enum data object.
Public method Static member CreateIFCAggregate Creates an IFCAggregate data object.
Public method Static member CreateIFCAnyHandle Creates an IFCAnyHandle data object.
Public method Static member CreateInteger Creates an integer data object.
Public method Static member CreateIntegerOfType Creates an integer data object of the specified type.
Public method Static member CreateLogical Creates a logical data object.
Public method Static member CreateLogicalOfType Creates a logical data object of the specified type.
Public method Static member CreateString Creates a string data object.
Public method Static member CreateStringOfType Creates a string data object of the specified type.
Public method Dispose Releases all resources used by the IFCData
Public method Equals Determines whether the specified Object is equal to the current Object .
(Overrides Object Equals(Object) )
Public method GetHashCode Gets the hash code.
(Overrides Object GetHashCode )
Public method GetSimpleType Gets the IFC type name.
Public method GetTypeList Gets the multiple strings represent one IFC type name.
Public method HasSimpleType Determines if there is one corresponding IFC type.
Public method SetSimpleType Sets the corresponding IFC type by its name.
Public method SetTypeList
Top
Operators
Name Description
Public operator Static member Equality(IFCData, IFCData) Determines whether two IFCDatas are the same.
Public operator Static member Inequality(IFCData, IFCData) Determines whether two IFCDatas are different.
Top
See Also