ActiveUIDocument Property


UIApplication Active UIDocument Property

Provides access to an object that represents the currently active project.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual UIDocument ActiveUIDocument { get; }

Property Value

UIDocument
Exceptions
Exception Condition
InvalidOperationException Thrown when attempting to modify the property.
Remarks
External API commands can access this property in read-only mode only! The ability to modify the property is reserved for future implementations.
See Also