IFailuresProcessor Interface


IFailures Processor Interface

To create your own UI or fully automated tool to process Revit Failures, derive a class from this interface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public interface IFailuresProcessor

The IFailuresProcessor type exposes the following members.

Methods
Name Description
Public method Dismiss This method is being called in case of exception or document destruction to dismiss any possible pending failure UI that may have left on the screen
Public method ProcessFailures Method that Revit will invoke to process failures at the end of transaction.
Top
Remarks
To override Revit default Failures Processing UI, instantiate your own processor derived from this interface and register it in Revit application.
See Also