IsPending Property


External Event Is Pending Property

Checking whether an event has been raised but not yet executed.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsPending { get; }

Property Value

Boolean
Remarks
When an event is requested to raise it is not executed immediately; instead, it waits for the next possible opportunity, which is determined by various internal conditions in Revit (policy similar to invoking external commands). When the opportunity comes, the event is executed by calling the event's handler. In the meantime, the event is 'Pending'.
See Also