Reinforcement |
A base class providing access to reinforcement rounding overrides for structural elements.

System Object
Autodesk.Revit.DB.Structure ReinforcementRoundingManager
Autodesk.Revit.DB.Structure FabricRoundingManager
Autodesk.Revit.DB.Structure RebarRoundingManager
Autodesk.Revit.DB.Structure ReinforcementRoundingManager
Autodesk.Revit.DB.Structure FabricRoundingManager
Autodesk.Revit.DB.Structure RebarRoundingManager
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ReinforcementRoundingManager type exposes the following members.

Name | Description | |
---|---|---|
![]() | Element | The owner of the reinforcement rounding overrides. |
![]() | IsActiveOnElement | Defines whether reinforcement rounding is activated for the particular element. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the ReinforcementRoundingManager |
![]() | GetLengthUnitTypeId | Gets the identifier of the length unit quantifying the reinforcement rounding values. |

Subclasses of this class are used to access the override settings for Rebar elements and types or Fabric elements and types.