CanExecute Event


Add In Command Binding Can Execute Event

Occurs when the command associated with this AddInCommandBinding initiates a check to determine whether the command can be executed on the command target.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public event EventHandler<CanExecuteEventArgs> CanExecute

Value

EventHandler CanExecuteEventArgs
Remarks
This callback will be called by Revit's user interface any time there is a contextual change. Therefore, the callback must be fast and is not permitted to be blocking in any way.
See Also