DimensionSegment Class


Dimension Segment Class

A segment of a dimension within the Autodesk Revit project.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB DimensionSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DimensionSegment : APIObject

The DimensionSegment type exposes the following members.

Properties
Name Description
Public property Above The text shown above the segment's value.
Public property Below The text shown below the segment's value.
Public property IsLocked Indicates if this segment is locked.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property LeaderEndPosition The position of the dimension leader end point.
Public property Origin The segment origin.
Public property Prefix The text shown before the segment's value.
Public property Suffix The text shown after the segment's value.
Public property Code example TextPosition The position of the dimension text's drag point.
Public property Value The length of the segment.
Public property ValueOverride The text that replaces the segment's value.
Public property ValueString The displayed value shown for the dimension segment.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsTextPositionAdjustable Indicates if this dimension is supported to set/get TextPosition/LeaderPosition.
Public method ResetTextPosition Resets the text position of the segment to the initial position determined by its type and parameters.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also