RebarCouplerError Enumeration


Rebar Coupler Error Enumeration

Error states for the Rebar Coupler

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum RebarCouplerError
Members
Member name Value Description
ArcsHaveDifferentCenters 16 Cannot place rebar couplers on arcs with different centers.
ArcsHaveDifferentRadii 15 Cannot place rebar couplers on arcs with different radii.
ArcToStraightSegment 17 Cannot connect by coupler a straight segment with an arc segment.
BarSegementsAreNotParallel 6 The selected legs are not aligned.
BarSegmentsAreNotOnSameLine 7 The selected legs are not aligned.
BarSegmentSmallerThanEngagement 13 The selected leg is shorter than the bar engagement.
BarsNotTouching 3 The selected ends of the bars are too far apart.
BendingPlanesAreNotParallel 18 The bending planes of the connected bars are not parallel. This will be returned when connecting two shape-driven rebars whose bending planes are not parallel and the bar curves that need to be connected are not aligned.
CurvesOtherThanLine 12 Cannot place rebar couplers on circular legs.
DifferentLayout 2 The rebar sets have different numbers of bars.
InconsistentShape 8 One of the selected bars has an incorrect shape.
IncorrectEndTreatmentCoupler 5 The coupler cannot be placed at an end that already has a coupler.
IncorrectEndTreatmentHook 4 The coupler cannot be placed at an end that already has a hook.
IncorrectInputData 1 Cannot place rebar coupler.
InvalidDiameter 9 The selected coupler type cannot be applied to the selected bar size(s).
ValidationSuccessfuly 0 Bars can be coupled
VaryingDistanceBetweenDistributionsBars 14 All the bars from the selected sets, which need to be connected, must be separated by the same distance.
See Also