GetNumberSystemReference Method


Stairs Run Get Number System Reference Method

Gets the number system reference corresponding to the given reference options.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Reference GetNumberSystemReference(
	StairsNumberSystemReferenceOption referenceOption
)

Parameters

referenceOption StairsNumberSystemReferenceOption
The reference option.

Return Value

Reference
The reference.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
The return value of this function is suitable for use in NumberSystem.Create() to associate a NumberSystem with the location on the StairsRun. Don't try to get geometry curve from the reference.
See Also