Entity Clear(Field) Method |
Resets the field to its default value.
Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentException | The Field belongs to a different Schema from this Entity, or this Entity is invalid. -or- This field's subschema prevents writing. |
ArgumentNullException | A non-optional argument was null |

The default value is zero for numeric fields, invalid value for identifiers and entities, and empty for strings and containers.