Performance |
Executes all rules in the list on a given document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- Document on which the rules will be executed.
Return Value
IList FailureMessageFailure messages explaining performance problems detected in the document.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Disabled rules are not executed.