GetTypeOfStorage Method


Document Get Type Of Storage Method

Get the storage type of the identified built-in parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public StorageType GetTypeOfStorage(
	ForgeTypeId parameterTypeId
)

Parameters

parameterTypeId ForgeTypeId
Identifier of the built-in parameter.

Return Value

StorageType
Storage type of the built-in parameter.
Exceptions
Exception Condition
ArgumentException parameterTypeId does not identify a built-in parameter. See Parameter.IsBuiltInParameter(ForgeTypeId) and Parameter.GetParameterTypeId(BuiltInParameter).
ArgumentNullException A non-optional argument was NULL
See Also