IndexLine Class


Index Line Class

A line segment primitive consisting of two indices.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IndexLine : IndexPrimitive

The IndexLine type exposes the following members.

Constructors
Name Description
Public method IndexLine Constructs the line segment primitive.
Top
Properties
Name Description
Public property Index0 The index of the line segment's first vertex.
Public property Index1 The index of the line segment's second vertex.
Top
Methods
Name Description
Public method Static member GetSizeInShortInts Gets the amount of storage that the primitive takes up in a buffer, measured in short integers.
Top
See Also