GetProjectionToSheetTransform Method


Viewport Get Projection To Sheet Transform Method

Returns the transform from the view's projection space to the sheet space.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Transform GetProjectionToSheetTransform()

Return Value

Transform
The transform from the view's projection space to the sheet space.
Exceptions
Exception Condition
InvalidOperationException The viewport is not on a sheet. -or- The viewport does not have transforms.
Remarks

This transform accounts for the position and rotation of a viewport on a sheet.

The transforms from the model space to the view projection space are returned by [!:View.GetModelToProjectionTransforms()] .

See Also