Location Class |
Provides location functionality for all elements.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Location
Autodesk.Revit.DB LocationCurve
Autodesk.Revit.DB LocationPoint
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Location
Autodesk.Revit.DB LocationCurve
Autodesk.Revit.DB LocationPoint
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The Location type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | Move | Move the element within the project by a specified vector. |
![]() | Rotate | Rotate the element within the project by a specified angle around a given axis. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The location object provides the ability to translate and rotate elements. More detailed location information and control can be found by using the derivatives of this object, such as LocationPoint or LocationCurve.