Location Class |
Provides location functionality for all elements.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Location
Autodesk.Revit.DB LocationCurve
Autodesk.Revit.DB LocationPoint
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Location
Autodesk.Revit.DB LocationCurve
Autodesk.Revit.DB LocationPoint
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The Location type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | Move | Move the element within the project by a specified vector. |
![]() | Rotate | Rotate the element within the project by a specified angle around a given axis. |

The location object provides the ability to translate and rotate elements. More detailed location information and control can be found by using the derivatives of this object, such as LocationPoint or LocationCurve.