Outline Contains Method |
Determine if this Outline contains the specified point to within a tolerance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- point XYZ
- The point to test for containment.
- tolerance Double
- The tolerance to use when determining whether the point is contained. Defaults to zero.
Return Value
BooleanTrue if this outline contains the given point, or false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

If the tolerance is positive, the point may lie up to the tolerance amount outside the outline in each coordinate. If the tolerance is negative, the point must lie at least the tolerance amount inside the outline in each coordinate.