DWGExportOptions Class


DWGExport Options Class

The export options used by exporting DWG format file.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DWGExportOptions : ACADExportOptions

The DWGExportOptions type exposes the following members.

Constructors
Name Description
Public method DWGExportOptions Constructs a new instance of DWGExportOptions with default values of all properties.
Public method DWGExportOptions(DWGExportOptions) Constructs a new instance of DWGExportOptions as a copy of the export options.
Top
Properties
Name Description
Public property ACAPreference The preferred way to generate geometry of ACA objects. Default value is ACAObjectPreference.Object.
(Inherited from ACADExportOptions )
Public property Colors Export color mode. Default value is ExportColorMode.IndexColors.
(Inherited from BaseExportOptions )
Public property ExportingAreas True to export area and room geometry, false otherwise. Default value is false.
(Inherited from ACADExportOptions )
Public property ExportOfSolids The mode used to export solids in 3D views. Default value is SolidGeometry.Polymesh.
(Inherited from ACADExportOptions )
Public property FileVersion ACADVersion::Default Default value is ACADVersion.Default.
(Inherited from ACADExportOptions )
Public property HatchBackgroundColor The color that will be set as hatch backgound color on the exported hatch. This color will be used only if useHatchBackgroundColor is true. default value is white
(Inherited from ACADExportOptions )
Public property HatchPatternsFileName Custom hatch patterns (pat) file name.
(Inherited from BaseExportOptions )
Public property HideReferencePlane Whether or not to hide reference planes. Default value is false.
(Inherited from BaseExportOptions )
Public property HideScopeBox Whether or not to hide the scope box. Default value is false.
(Inherited from BaseExportOptions )
Public property HideUnreferenceViewTags Whether or not to hide unreference view tags. Default value is false.
(Inherited from BaseExportOptions )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from BaseExportOptions )
Public property LayerMapping Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.
(Inherited from BaseExportOptions )
Public property LineScaling The scaling mode for the line type. Default value is LineScaling.ViewScale.
(Inherited from ACADExportOptions )
Public property LinetypesFileName The custom linetype file name (*.lin). Default value is empty.
(Inherited from ACADExportOptions )
Public property MarkNonplotLayers If true and the nonplot layer suffix is not empty, all layers whose names contain that suffix will be marked as non-plot.
(Inherited from ACADExportOptions )
Public property MergedViews Whether to merge all views in one file (via XRefs). Default value is false for mergedViews.
Public property NonplotSuffix If the MarkNonplotLayers attribute is set to true, all layers with names containing this suffix will be marked as non-plot. No action will be performed if the suffix is empty.
(Inherited from ACADExportOptions )
Public property PreserveCoincidentLines Whether or not to preserve coincident lines. Default value is false.
(Inherited from BaseExportOptions )
Public property PropOverrides How to export overridden object styles. Default value is PropOverrideMode.ByEntity.
(Inherited from BaseExportOptions )
Public property SharedCoords True to use the shared coordinate system's origin, false to use the project origin. Default value is false.
(Inherited from ACADExportOptions )
Public property TargetUnit The target unit type. Default value is ExportUnit.Default.
(Inherited from ACADExportOptions )
Public property TextTreatment The text treatment. Deault value is TextTreatment.Exact.
(Inherited from ACADExportOptions )
Public property UseHatchBackgroundColor Indicates if hatch background color will be used or not. default value is false.
(Inherited from ACADExportOptions )
Top
Methods
Name Description
Public method Dispose
(Inherited from BaseExportOptions )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetExportFontTable Gets font table.
(Inherited from BaseExportOptions )
Public method GetExportLayerTable Gets the layer table.
(Inherited from BaseExportOptions )
Public method GetExportLinetypeTable Gets a copy of the line type table.
(Inherited from BaseExportOptions )
Public method GetExportPatternTable Gets a copy of the pattern table.
(Inherited from BaseExportOptions )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Static member GetPredefinedOptions Returns an instance DWGExportOptions containing settings from a predefined export setup.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetExportFontTable Sets font table to option.
(Inherited from BaseExportOptions )
Public method SetExportLayerTable Sets layer table back to option
(Inherited from BaseExportOptions )
Public method SetExportLinetypeTable Sets the line type table to use during export.
(Inherited from BaseExportOptions )
Public method SetExportPatternTable Sets the pattern table to use during export.
(Inherited from BaseExportOptions )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also