ExportPatternTable Class


Export Pattern Table Class

A table supporting a mapping of FillPatterns in Revit to pattern names that will be set in the target export format.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExportPatternTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExportPatternTable : IEnumerable<KeyValuePair<ExportPatternKey, ExportPatternInfo>>, 
	IDisposable

The ExportPatternTable type exposes the following members.

Constructors
Name Description
Public method ExportPatternTable Constructs a new ExportPatternTable with default values.
Top
Properties
Name Description
Public property Count Count of the items contained in the collection.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Item A copy of the ExportPatternInfo for the pattern's ExportPatternKey .
Top
Methods
Name Description
Public method Add Inserts a (key,info) pair into Export pattern table.
Public method Clear Removes all contents stored in the table.
Public method ContainsKey Checks whether a pattern key exists in the table.
Public method Dispose Releases all resources used by the ExportPatternTable
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Public method GetExportPatternInfo Gets a copy of the pattern info associated to the input pattern key.
Public method GetKeys Gets all the keys stored in the map.
Public method GetPatternTableIterator Returns a PatternTableIterator that iterates through the collection.
Public method GetValues Returns all the values stored in the map.
Public method Remove Removes the pair (key, info) by pattern key.
Top
Remarks

This table is structured as a mapping from ExportPatternKey to ExportPatternInfo members. The ExportPatternKey contains the identification information for the pattern table: the Revit fill pattern type and name. The ExportPatternInfo contains the pattern name to use in the export format.

The table can be accessed via direct iteration as a collection of KeyValuePairs, or by traversal of the stored keys obtained from GetKeys(), or via specific lookup of a key constructed externally. In all cases, the ExportPatternInfo returned will be a copy of the ExportPatternInfo from the table. In order to make changes to the ExportPatternInfo and use those settings during export, set the modified ExportPatternInfo back into the table using the same key.

See Also