SetLinkOverrides Method


View Set Link Overrides Method

Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetLinkOverrides(
	ElementId linkId,
	RevitLinkGraphicsSettings linkDisplaySettings
)

Parameters

linkId ElementId
The id of the RevitLinkType or RevitLinkInstance .
linkDisplaySettings RevitLinkGraphicsSettings
Settings representing all link graphic overrides in the view.
Exceptions
Exception Condition
ArgumentException The input id is not a valid RevitLinkInstance or RevitLinkType id. -or- The LinkedViewId of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The ViewFilterType of linkDisplaySettings has incorrect value. -or- The ViewRange of linkDisplaySettings has unsupported value. -or- The phase or pahse type of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The phase filter or phase filter type of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The view detail level or the type of view detail level of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The discipline or the discipline type of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The ColorFill of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The ObjectStyles of linkDisplaySettings has incorrect value for the specified LinkVisibilityType. -or- The NestedLinks of linkDisplaySettings has incorrect value for the specified LinkVisibilityType.
ArgumentNullException A non-optional argument was null
InvalidOperationException The view type does not support Visibility/Graphics Overriddes. -or- The view does not support link graphical overrides.
See Also