GetAttachmentIds Method


Wall Get Attachment Ids Method

Gets the ids of the target elements that are attached to the Wall.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public IList<ElementId> GetAttachmentIds(
	AttachmentLocation attachmentLocation
)

Parameters

attachmentLocation AttachmentLocation
The attachment location.

Return Value

IList ElementId
Returns the elements ids that are attached to this wall at the specified "attachmentLocation".
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also