Create Method (Document, ElementId, ElementId, ElementId, RailingPlacementPosition)


Railing Create(Document, Element Id, Element Id, Element Id, Railing Placement Position) Method

Creates new railings with the specified railing type on all sides of a stairs instance in a MultistoryStairs element.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ISet<ElementId> Create(
	Document document,
	ElementId multistoryStairsId,
	ElementId levelId,
	ElementId railingTypeId,
	RailingPlacementPosition placePosition
)

Parameters

document Document
The document.
multistoryStairsId ElementId
The id of the MultistoryStairs that contains the stairs which will be the host of this railing. The stairs should have no associated railings yet.
levelId ElementId
The level of stairs on which the new railing will be created. The level should be one of levels defining the MultistoryStairs element.
railingTypeId ElementId
The railing type of the new railing to be created.
placePosition RailingPlacementPosition
The placement position of the new railing.

Return Value

ISet ElementId
The new railing instances successfully created on the stairs.
Exceptions
Exception Condition
ArgumentException The railingTypeId is not a railing type. -or- The ElementId levelId is not a Level. -or- The levelId is not a level of MultistoryStairs stairs element.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException The multistoryStairsId already has associated railings or is in editing mode so association of railings is not permitted.
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
See Also