LoadFamily Method (String)


Document Load Family(String) Method

Loads an entire family and all its types/symbols into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool LoadFamily(
	string filename
)

Parameters

filename String
The fully qualified filename of the Family file, usually ending in .rfa.

Return Value

Boolean
True if the entire family was loaded successfully into the project, otherwise False.
Exceptions
Exception Condition
ArgumentException Thrown when filename is or empty.
Remarks

Loading an entire family may take a considerable amount of time and memory. It is recommended that you use one of the LoadFamilySymbol() methods and only load those symbols that you need.

See Also