RenderingQualitySettings Class


Rendering Quality Settings Class

Represents the quality settings of rendering.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RenderingQualitySettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RenderingQualitySettings : IDisposable

The RenderingQualitySettings type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LightAndMaterialAccuracyMode A value that controls light and material accuracy mode.
Public property RenderDuration A value that controls render duration.
Public property RenderingQuality The quality applied for rendering.
Public property RenderLevel The render target level as a numerical value between 1 and 40.
Public property RenderTime The render target time as a numerical value between 1 and 32768.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RenderingQualitySettings
Public method IsCustomQuality Checks if the current rendering quality is custom or not.
Public method IsValidRenderLevel Validate the render level is between 1 and 40
Public method IsValidRenderTime Validate the render time is between 1 and 32768.
Top
Remarks
The other properties in this class can only be modified if the RenderingQuality property is currently set to Custom.
See Also