Document Enable |
Enables cloud worksharing for a cloud model
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
CentralModelAccessDeniedException | Access to the cloud model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance. |
CentralModelContentionException | The central model is locked by another client. |
CentralModelException | The model in cloud is missing. -or- The model in cloud is incompatible. -or- The model in cloud is corrupt or not an RVT file. -or- The model in cloud was rolled back. -or- An internal error happened on the model in cloud , please contact the administrator. |
FileNotFoundException | Cannot access the local cache. |
InvalidOperationException | This Document is not a primary document, it is a linked document. -or- This Document is read-only: It cannot be modified. -or- This Document has an open editing transaction and is accepting changes. -or- This Document is not a project document. -or- This Document is in an edit mode. -or- Saving is not allowed in the current application mode. -or- This Document does not have a central location: Worksharing needs to be enabled and central model saved. -or- The file is read-only, can not be saved. -or- The cloud model does not allow cloud worksharing to be enabled. -or- Operation is not permitted when there is any open sub-transaction, transaction, or transaction group. |
RevitServerCommunicationException | Could be for any of the reasons related to network. |
RevitServerInternalException | Could be for any of the reasons that conversion fails with RevitServerInternalException. |
RevitServerUnauthenticatedUserException | User is not signed in with Autodesk id. |
RevitServerUnauthorizedException | You do not have workshared cloud model entitlement to access this resource in cloud -or- User is not authorized to access the specified cloud project. |

This operation will convert an existing cloud model to a workshared cloud model. This method cannot be used if current model is not a cloud model. This method cannot be used if the current user doesn't have the workshared cloud model entitlement.