RebarShapeConstraintFixedSegmentDir Class


Rebar Shape Constraint Fixed Segment Dir Class

A constraint that can be applied to a RebarShapeSegment and fixes the direction of the segment in UV-space.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintFixedSegmentDir

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeConstraintFixedSegmentDir : RebarShapeConstraint

The RebarShapeConstraintFixedSegmentDir type exposes the following members.

Constructors
Name Description
Public method RebarShapeConstraintFixedSegmentDir Create a fixed segment direction constraint.
Top
Properties
Name Description
Public property Direction The direction of the RebarShapeSegment in UV-space.
Top
Methods
Name Description
Top
See Also