RebarShapeConstraintFixedSegmentDir Class


Rebar Shape Constraint Fixed Segment Dir Class

A constraint that can be applied to a RebarShapeSegment and fixes the direction of the segment in UV-space.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarShapeConstraint
Autodesk.Revit.DB.Structure RebarShapeConstraintFixedSegmentDir

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeConstraintFixedSegmentDir : RebarShapeConstraint

The RebarShapeConstraintFixedSegmentDir type exposes the following members.

Constructors
Name Description
Public method RebarShapeConstraintFixedSegmentDir Create a fixed segment direction constraint.
Top
Properties
Name Description
Public property Direction The direction of the RebarShapeSegment in UV-space.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RebarShapeConstraint )
Top
Methods
Name Description
Public method Dispose
(Inherited from RebarShapeConstraint )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetParamId Return the Id of the parameter associated with this constraint.
(Inherited from RebarShapeConstraint )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also