ConduitSize Class


Conduit Size Class

Stores the basic size information for a conduit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Electrical ConduitSize

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConduitSize : IDisposable

The ConduitSize type exposes the following members.

Constructors
Name Description
Public method ConduitSize Constructs an object that stores the basic size information for conduit.
Top
Properties
Name Description
Public property BendRadius Minimum bend radius
Public property InnerDiameter Inner diameter
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property NominalDiameter Nominal diameter
Public property OuterDiameter Outer diameter
Public property UsedInSizeLists Whether it is used in size lists.
Public property UsedInSizing Whether is used in sizing.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ConduitSize
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also