FilterStringGreaterOrEqual Class


Filter String Greater Or Equal Class

Tests whether string values from the document would sort after or match a certain string.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FilterStringRuleEvaluator
Autodesk.Revit.DB FilterStringGreaterOrEqual

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterStringGreaterOrEqual : FilterStringRuleEvaluator

The FilterStringGreaterOrEqual type exposes the following members.

Constructors
Name Description
Public method FilterStringGreaterOrEqual Constructs an instance of FilterStringGreaterOrEqual.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterStringRuleEvaluator )
Top
Methods
Name Description
Public method Dispose
(Inherited from FilterStringRuleEvaluator )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Evaluate Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
(Inherited from FilterStringRuleEvaluator )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also