SplitButtonData Constructor


Split Button Data Constructor

Constructs a new instance of SplitButtonData.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public SplitButtonData(
	string name,
	string text
)

Parameters

name String
The internal name of the new button.
text String
Exceptions
Exception Condition
ArgumentNullException Thrown when is passed for one or more arguments.
ArgumentException Thrown when an empty string is passed for one or more arguments.
Remarks
This text will be displayed on the button if drop-down is empty. If sub-items are added, then the split button will display the current PushButton's text.
See Also