Join |
Reverses the order in which two elements are joined.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static void SwitchJoinOrder(
Document document,
Element firstElement,
Element secondElement
)
Parameters

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined. -or- The elements cannot be joined. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Unable to switch the join order of these elements. |

The cutting element becomes the cut element and vice versa after the join order is switched. This functionality is not available for family documents.