Element |
The ElementId object is used as a unique identification for an element within a single project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ElementId type exposes the following members.

Name | Description | |
---|---|---|
![]() | ElementId(BuiltInCategory) | Create an ElementId handle with the given BuiltInCategory id. |
![]() | ElementId(BuiltInParameter) | Create an ElementId handle with the given BuiltInParameter id. |
![]() | ElementId(Int32) | Obsolete. Create an ElementId handle with the given 32-bit integer id. |
![]() | ElementId(Int64) | Create an ElementId handle with the given 64-bit integer id. |

Name | Description | |
---|---|---|
![]() | IntegerValue | Obsolete. Provides the value of the element id as a 32-bit integer. |
![]() ![]() | InvalidElementId | Get the invalid ElementId whose value is -1. |
![]() | Value | Provides the value of the element id as a 64-bit integer. |

Name | Description | |
---|---|---|
![]() | Compare | Compares two element ids. |
![]() | Equals | Determines whether the specified Object is equal to the current Object . (Overrides Object Equals(Object) ) |
![]() | GetHashCode | Gets the value of the id as hash code (Overrides Object GetHashCode ) |
![]() ![]() | Parse | Parse the string representation of the id into a corresponding ElementId. |
![]() | ToString | Gets a String representation of the value of the id. (Overrides Object ToString ) |
![]() ![]() | TryParse | Parse the string representation of the id into a corresponding ElementId. |

Name | Description | |
---|---|---|
![]() ![]() | Equality(ElementId, ElementId) | Determines whether these two ElementIds are the same. |
![]() ![]() | GreaterThan(ElementId, ElementId) | Determines whether one element id is greater than another element id. |
![]() ![]() | GreaterThanOrEqual(ElementId, ElementId) | Determines whether one element id is not less than another element id. |
![]() ![]() | Inequality(ElementId, ElementId) | Determines whether these two ElementIds are different. |
![]() ![]() | LessThan(ElementId, ElementId) | Determines whether this element id is less than another element id. |
![]() ![]() | LessThanOrEqual(ElementId, ElementId) | Determines whether one element id is not greater than another element id. |

The Value within the ElementId is only unique with a single project. It is not unique across several projects. The Id can be used to retrieve a specific element from the database when needed. However ids are subject to change during an Autodesk Revit session and as such should not be retained and used across repeated calls to external commands. If a manner is needed to uniquely identify an element beyond this limitation then a shared parameter should be added to the element containing a unique identifier managed by the external application.