UIControlledApplication Class


UIControlled Application Class

Represents the Autodesk Revit user interface, providing access to UI customization methods and events.
Inheritance Hierarchy
System Object
Autodesk.Revit.UI UIControlledApplication

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class UIControlledApplication

The UIControlledApplication type exposes the following members.

Properties
Name Description
Public property ActiveAddInId
Public property ControlledApplication Returns the database level ControlledApplication represented by this UI-level ControlledApplication.
Public property IsLateAddinLoading Indicates whether this add-in is loaded on the fly or not. If it is loaded when Revit is starting up, it is false, otherwise it should be true.
Public property IsViewerModeActive Identifies if the current Revit session is running in Viewer mode
Public property LoadedApplications
Public property MainWindowHandle
Public property ProductIsRS
Top
Methods
Name Description
Public method CreateAddInCommandBinding
Public method CreateRibbonPanel(String)
Public method CreateRibbonPanel(String, String)
Public method CreateRibbonPanel(Tab, String)
Public method CreateRibbonTab
Public method GetDockablePane
Public method GetRibbonPanels
Public method GetRibbonPanels(String)
Public method GetRibbonPanels(Tab)
Public method LoadAddIn
Public method LoadPackageContents
Public method RegisterContextMenu
Public method RegisterDockablePane
Public method RemoveAddInCommandBinding
Top
Events
Name Description
Public event ApplicationClosing Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
Public event DialogBoxShowing Subscribe to the DialogBoxShowing event to be notified when Revit is just about to show a dialog box or a message box.
Public event DisplayingOptionsDialog Subscribe to the options dialog displaying event to be notified when Revit options dialog is displaying.
Public event DockableFrameFocusChanged Subscribe to GenericDockableFrame activated event to be notified when Revit GenericDockableFrame is active or inactive.
Public event DockableFrameVisibilityChanged Subscribe to GenericDockableFrame showing or hiding event to be notified when Revit GenericDockableFrame is showing or hiding.
Public event ExternalDataManagerChanged Subscribe to the ExternalDataManager changed event to be notified.
Public event FabricationPartBrowserChanged Subscribe to MEP Fabrication part browser changed event to be notified when MEP Fabrication part browser is updated.
Public event FormulaEditing Subscribe to the FormulaEditing event
Public event Idling Subscribe to the Idling event to be notified when Revit is not in an active tool or transaction.
Public event SelectionChanged Subscribe to the SelectionChanged event to be notified after the selection was changed.
Public event ThemeChanged Subscribe to the ThemeChanged event to be notified after the theme was changed.
Public event TransferredProjectStandards Subscribe to the TransferredProjectStandards event to be notified after the scope of a Transfer Project Standards operation has been finalized in the Transfer Project Standards dialog.
Public event TransferringProjectStandards Subscribe to the TransferringProjectStandards event to be notified before the scope of an impending Transfer Project Standards operation has been finalized.
Public event ViewActivated Subscribe to the ViewActivated event to be notified immediately after Revit has finished activating a view of a document.
Public event ViewActivating Subscribe to the ViewActivating event to be notified when Revit is just about to activate a view of a document.
Top
Remarks
This class does not provide access to documents because it is provided to you through the ExternalApplication OnStartup()/OnShutdown() methods, and those methods are when it is not possible to work with Revit documents. You can work with documents by getting them from the UIApplication class; that class is obtained from events and ExternalCommand callbacks.
See Also