ElementTypeDuplicated Event


Controlled Application Element Type Duplicated Event

Subscribe to the ElementTypeDuplicated event to be notified immediately after Revit has finished duplicating an element type.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public event EventHandler<ElementTypeDuplicatedEventArgs> ElementTypeDuplicated

Value

EventHandler ElementTypeDuplicatedEventArgs
Remarks

This event is raised immediately after Revit has finished duplicating an element type. It is raised even when duplicating an element type failed or was cancelled (during ElementTypeDuplicating event).

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Check the 'Status' field in event's argument to see whether the action itself was successful or not.

This event is not cancellable, for the process of importing has already been finished.

If the action was not successful, the document may not be modified and new transactions may not be started.

The following API functions are not available for the current document during this event:

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

See Also