Failure |
Sets the default resolution type for the failure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- type FailureResolutionType
- The type of resolution to be used as default.
Return Value
FailureDefinitionThe FailureDefinition.

Exception | Condition |
---|---|
ArgumentException | Resolution of the type is not applicable to the failure. |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
InvalidOperationException | FailureDefinition does not have any resolutions. |

If failure has multiple resolutions, one of them is designated as designated as the default resolution. The default resolution is used by Revit failure processing mechanism to resolve failures automatically when applicable.