BasicFileInfo Class


Basic File Info Class

Encapsulates basic information about a Revit file, including worksharing status, Revit version, username and central path.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BasicFileInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BasicFileInfo : IDisposable

The BasicFileInfo type exposes the following members.

Properties
Name Description
Public property AllLocalChangesSavedToCentral Are all local changes saved to the central file?
Public property CentralPath Returns the central model path.
Public property Format The file format indicator (currently, the major release version such as "2019") used for saving the file.
Public property IsCentral Checks if the file is workshared and Central.
Public property IsCreatedLocal Checks if the file is local and created by RevitServerTool.exe.
Public property IsInProgress Checks if the file is workshared and is in process of becoming Central.
Public property IsLocal Checks if the file is workshared and Local.
Public property IsSavedInCurrentVersion Checks if the file is saved in the current version.
Public property IsSavedInLaterVersion Checks if the file is saved in a later version of Revit than the running Revit.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property IsWorkshared Checks if the file is workshared.
Public property LanguageWhenSaved Return the language active for the last save
Public property LatestCentralEpisodeGUID This is the central model's episode GUID corresponding to the last reload latest done for this model.
Public property LatestCentralVersion This is the central model's version number corresponding to the last reload latest done for this model.
Public property Username Returns the username.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the BasicFileInfo
Public method Static member Extract Returns an instance of BasicFileInfo filled with basic information about a Revit file located at the given file-path
Public method GetDocumentVersion Gets the DocumentVersion for the file.
Top
Remarks
This class provides a fast access to get basic information without fully opening a Revit file. The Extract method can initialize a new instance of this class by providing a full path for Revit file, including project (.rvt) and family (.rfa) files. This class can extract information from files of older formats. If the structure of the BasicFileInfo storage has not changed, it can also extract information from files of newer formats (making the method IsSavedInLaterVersion relevant). However, if the structure of the storage has changed in a newer file format, Extract will not be able to extract the information.
See Also