GetWarnings Method


Document Get Warnings Method

Returns list of failure messages generated from persistent (reviewable) warnings accumulated in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<FailureMessage> GetWarnings()

Return Value

IList FailureMessage
List of failure messages representing warnings accumulated in the document.
Remarks
Function returns list of failure messages identical to the list displayed in a warning dialog when command Manage tab->Inquiry pane->Review Warnings is issued through the UI. Operations performed on the returned list by the caller do not impact information about warnings stored in the document.
See Also