GetGrossFloorArea Method


Mass Instance Utils Get Gross Floor Area Method

Get the total occupiable floor area represented by a mass instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static double GetGrossFloorArea(
	Document document,
	ElementId massInstanceId
)

Parameters

document Document
The Document.
massInstanceId ElementId
The ElementId of the mass instance.

Return Value

Double
The gross floor area in square feet.
Exceptions
Exception Condition
ArgumentException The ElementId massInstanceId is not a mass instance.
ArgumentNullException A non-optional argument was null
Remarks
The area is computed from the cross sections that are created by intersecting the associated Levels with the mass instance Geometry.
See Also