Period Property


Face Period Property

The period of the underlying surface in the specified parametric direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double this[
	int paramIdx
] { get; }

Parameters

paramIdx Int32
Use 0 for U coordinates and 1 for V coordinates.

Return Value

Double
The real number equal to the period of the underlying surface.
Exceptions
Exception Condition
ArgumentOutOfRangeException Thrown when an incorrect coordinate dimension is supplied.
InvalidOperationException Thrown when this face is not cyclic in the specified direction.
See Also