Behavior |
An enumerated type listing all the behavior type for MEP Components.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)


Member name | Value | Description |
---|---|---|
BaseObject | 1,024 | BehaviorType is Base Object |
Bend | 2 | BehaviorType is Bend |
Branch | 4 | BehaviorType is Branch |
BreakInto | 32 | BehaviorType is Break Into |
Coupling | 2,097,152 | BehaviorType is Coupling |
Damper | 16,777,216 | BehaviorType is a round centreline tap on oval straight |
ElectricalBaseObject | 65,536 | BehaviorType is Electrical Base Object |
EndCap | 2,048 | BehaviorType is End Cap |
Flange | 8,192 | BehaviorType is Flange |
Flat_Tap | 1,048,576 | BehaviorType is a flat tap on flat surface, eg. rectangular straight or flat-side of oval straight |
Flex | 262,144 | BehaviorType is Flex |
Hanger | 524,288 | BehaviorType is Hanger |
Inline | 16 | BehaviorType is Inline |
Intersection | 8 | BehaviorType is Intersection |
Invalid | 0 | BehaviorType is Invalid |
MechanicalCoupling | 16,384 | BehaviorType is Mechanical Coupling |
Normal | 1 | BehaviorType is Normal |
OrientToCenterLine | 128 | BehaviorType is Orient to CenterLine |
OrientToFace | 256 | BehaviorType is Orient to Face |
OrientToObject | 64 | BehaviorType is Orient to Object |
Oval_CentreLine_Tap | 8,388,608 | BehaviorType is a round centreline tap on oval straight |
Round_CentreLine_Tap | 4,194,304 | BehaviorType is a round centreline tap on round straight/pipe |
Straight | 131,072 | BehaviorType is Straight |
SystemMember | 512 | BehaviorType is System Member |
Valve | 4,096 | BehaviorType is Valve |
VerticalBend | 32,768 | BehaviorType is Vertical Bend |