MacroManager Class


Macro Manager Class

Manager object for the Macro modules of the application.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Macros MacroManager

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPIMacros (in RevitAPIMacros.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MacroManager : IEnumerable<MacroModule>, 
	IDisposable

The MacroManager type exposes the following members.

Properties
Name Description
Public property Count The count.
Public property Folder The modules folder.
Public property IsEnabled Indicates if macros stored in this MacroManager are enabled.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method AddModule Adds a MacroModule to the application.
Public method Contains Indicates the given module is a member of this collection.
Public method Dispose Releases all resources used by the MacroManager
Public method Static member GetApplicationMacroSecurityOptions Gets the application macro security options.
Protected method GetBasicIEnumerator Returns an enumerator that iterates through a collection.
Public method GetEnumerator Returns an enumerator that iterates through a collection.
Public method Static member GetMacroManager Gets the Macro manager from the application.
Public method GetMacroManagerIterator Returns a Macro manager iterator that iterates through the collection.
Public method RemoveModule Removes a MacroModule.
Public method Static member SetApplicationMacroSecurityOptions Sets the application macro security options.
Top
See Also