NewFamilyInstance Method (XYZ, FamilySymbol, StructuralType)


Item Factory Base New Family Instance(XYZ, Family Symbol, Structural Type) Method

Inserts a new instance of a family into the document, using a location and a type/symbol.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilyInstance NewFamilyInstance(
	XYZ location,
	FamilySymbol symbol,
	StructuralType structuralType
)

Parameters

location XYZ
The physical location where the instance is to be placed.
symbol FamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
structuralType StructuralType
If structural then specify the type of the component.

Return Value

FamilyInstance
A valid instance of the given family if the creation is successful. An exception will be thrown otherwise.
Exceptions
Exception Condition
ArgumentException Thrown if the symbol is not active.
InvalidOperationException Thrown if the family is level-based, for new instances of such families require a valid level to be supplied at the time of creation.
Remarks
Use this method to insert a family instance that does not require a host element or level. For creating instances of level-based families use one of the NewFamilyInstance methods of the Revit.Creation.Document class.

The type/symbol that is used must be loaded into the document before this method is called. Families and their symbols can be loaded using the Document.LoadFamily or Document.LoadFamilySymbol methods.

Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point instances. Once inserted these linear family instances can have their endpoints changed by using the instance's Element.Location property.

Note: if the created family instance includes nested instances, the API framework will automatically regenerate the document during this method call.

See Also