Spatial |
The position of the tag's head.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentException | When setting this property: Head position of the tag with no leader could not be located outside of the host element. |
ArgumentNullException | When setting this property: A non-optional argument was null |
InvalidOperationException | When setting this property: SpatialElementTag is pinned. -or- When setting this property: SpatialElementTag is orphaned. |

Returns the end point of the tag leader. Leader end point must be located inside of a room, space or an area. Use Room.IsPointInRoom or Space.IsPointInSpace method to check whether the leaderEnd is located in the host element or not.